准备将jpush更新到新版的3.0+版本。

自己的pod仓库, pod lint 发现无法通过验证:

- NOTE  | [iOS] xcodebuild:  ld: warning: ignoring file JPush/libjpush-ios-3.0.7.a, missing required architecture i386 in file JPush/libjpush-ios-3.0.7.a (4 slices)

解决方法,podspec添加:

s.xcconfig = {
    'VALID_ARCHS' =>  'arm64 x86_64',
  }