http://www.yiichina.com/doc/guide/2.0/start-installation

通过 Composer 安装

如果你已经安装有 Composer 请确保使用的是最新版本, 你可以用 composer self-update 命令更新 Composer 为最新版本。

➜  ~ composer self-update
You are already using composer version 1.4.2 (stable channel).

Composer 安装后,切换到一个可通过 Web 访问的目录,执行如下命令即可安装 Yii :

composer global require "fxp/composer-asset-plugin:^1.2.0"
composer create-project --prefer-dist yiisoft/yii2-app-basic basic

第一条命令安装 Composer asset plugin, 它是通过 Composer 管理 bower 和 npm 包所必须的,此命令全局生效,一劳永逸。 第二条命令会将 Yii 安装在名为 basic 的目录中。如果你想使用其它目录名称,你可以选择其他目录名称。

注意: 在安装过程中 Composer 可能会询问你 GitHub 账户的认证信息,因为可能在使用中超过了 GitHub API (对匿名用户的)使用限制。因为 Composer 需要为所有扩展包从 GitHub 中获取大量信息,所以超限非常正常。(译注:也意味着作为程序猿没有 GitHub 账号,就真不能愉快地玩耍了)登陆 GitHub 之后可以得到更高的 API 限额,这样 Composer 才能正常运行。更多细节请参考 Composer 文档(该段 Composer中文文档期待您的参与)。

提示: 如果你想安装 Yii 的最新开发版本,可以使用以下命令代替, 它添加了一个 stability 选项(中文版): composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-basic basic 注意,Yii 的开发版(dev 版)不应该用于生产环境中,它可能会破坏运行中的代码。

2017071270033AD60652A-B631-4897-B46F-EA6B776F2875.png

尝试使用

cd Yii/basic
php yii serve #默认端口8080

直接访问http://localhost:8080

指定端口命令为: php yii serve --port=8888

如果目录在web目录下访问,Yii框架中的web目录也可以显示成功

如:http://localhost/Yii/basic/web/